[Réglé] Support de l'utilisationErreur 500 après suppression page de l'extension page

Forum de support pour toutes les questions concernant l'utilisation de phpBB toutes versions. les problèmes rencontrés lors de manipulations et de la configuration du forum.
no_avatar
France leroidugazon
Auteur du sujet
Messages : 31
Enregistré le : 20 novembre 2018
Liquide : 253.40
Localisation : Haut de France
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France leroidugazon » 28 janv. 2019, 19:13
Bonjour,

Je viens vers vous car j'ai supprimé une page de l'extension page et maintenant je me retrouve avec une erreur de type : HTTP ERROR 500

voici le lien du site : https://www.forumgazon.fr

comment résoudre ce soucis

voici l’erreur en question :
Fatal error: Class phpbb\db\driver\factory contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (phpbb\db\driver\driver_interface::cast_expr_to_strhng) in /var/www/clients/client0/web1/web/phpbb/db/driver/factory.php on line 21

merci pour votre aide

bien à vous

Leroidugazon
Modifié en dernier par France leroidugazon le 29 janv. 2019, 08:35, modifié 1 fois.


Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 530
Enregistré le : 13 janvier 2018
Liquide : 3 203.45
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France Sylver35 » 28 janv. 2019, 19:22
Bonjour,

Comment a-tu supprimé la page?

A-tu tenté de vider le cache?
Si tu ne peut pas le faire via le forum, le faire via ftp
.
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
no_avatar
France leroidugazon
Auteur du sujet
Messages : 31
Enregistré le : 20 novembre 2018
Liquide : 253.40
Localisation : Haut de France
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France leroidugazon » 28 janv. 2019, 19:25
bonsoir, Sylver

j'ai supprimer la page en passant par l'extension page et supprimer la page avec la croix rouge.
j'ai vidé le cache du forum via FTP.

voici ce que j'ai en ligne 21 du fichier en question : class factory implements driver_interface

merci de ton aide

bien à toi

JM
Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 530
Enregistré le : 13 janvier 2018
Liquide : 3 203.45
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France Sylver35 » 28 janv. 2019, 20:15
En attendant et pour voir, désactive l'extension page.
Dans la bdd, table "ext" tu met 0 pour page et tu vide le cache
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
no_avatar
France leroidugazon
Auteur du sujet
Messages : 31
Enregistré le : 20 novembre 2018
Liquide : 253.40
Localisation : Haut de France
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France leroidugazon » 28 janv. 2019, 20:50
je viens de désactiver l'extension page et vider le cache comme indiqué (mais le cache est totalement vide) mais toujours rien toujours la même erreur.

j'ai fait une capture écran des logs car il y a des numéros à droite mais il en manque normal ou pas ?
Capture50.PNG
Pour information l'erreur 500 est survenue aussitôt après avoir vidé la cache du forum par le panneau admin
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 530
Enregistré le : 13 janvier 2018
Liquide : 3 203.45
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France Sylver35 » 28 janv. 2019, 23:03
Pour information l'erreur 500 est survenue aussitôt après avoir vidé la cache du forum
Donc alors rien à voir du tout avec l'extension page !

Je te conseille de supprimer le dossier phpbb/ de ton forum et de remettre un dossier tout neuf venant du pack phpbb 3.2.5 puis voir si cela revient...
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
no_avatar
France leroidugazon
Auteur du sujet
Messages : 31
Enregistré le : 20 novembre 2018
Liquide : 253.40
Localisation : Haut de France
Pays :
France (fr)
France

Erreur 500 après suppression page de l'extension page

Message par France leroidugazon » 29 janv. 2019, 07:39
je viens de supprimer le fichier phpbb/ du pack ppour en remettre un tout nouveau mais toujours la même erreur

Y a t'il une solution pour réparer cela ou faut il envoyer une sauvegarde de la BDD sur le forum.

Merci pour votre aide

Le roi du gazon

Edit : le forum est revenu donc j'ai remis à neuf le dossier phpbb/ comme indiqué par Sylver
Ensuite erreur dans le dossier vendor que j'ai supprimé et j'ai transférer un nouveau dossier tout neuf et maintenant le forum fonctionne de nouveau.
Que c'est il passé au moment de la purge du cache et pourquoi une telle erreur.

Sylver je te remercie de ton aide et de m'avoir répondu hier à mes inquiétudes qui grâce à toi le soucis est résolu

JM :D
  • Sujets similaires
    Réponses
    Vues
    Dernier message