Support des Extensions phpBBProblème d'affichage drapeau countryflag

Support pour toutes les extensions phpBB développées par notre équipe et toutes les autres.
Avatar de ironside
France ironside
Auteur du sujet
Messages : 6
Enregistré le : 18 septembre 2020
Liquide : 79.70
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France ironside » 26 déc. 2021, 19:55
Bonsoir , j'ai un problème similaire.

je peux choisir le drapeaux , celui-ci s'affiche quand on le selectionne , mais aucun drapeaux ne s'affiche. (voir image ci-dessous)


Image


dans la barre d'adresse il y a ceci https://forum.ironside-legende.eu/%22https://forum.ironside-legende.eu/ext/sylver35/countryflag/flags/fr.png/%22


au lieu de https://forum.ironside-legende.eu/ext/sylver35/countryflag/flags/fr.png

cordialement


Image
Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 576
Enregistré le : 13 janvier 2018
Liquide : 3 478.95
Relax-Arcade :  2
Localisation : Bretagne
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France Sylver35 » 26 déc. 2021, 20:33
Bonjour,

J'ai divisé le message du sujet ou tu avais posté -> https://breizhcode.com/viewtopic.php?t=268
Toutes les demandes ne sont pas les mêmes et à chacun sont sujet, ne pas tout mélanger dans un sujet fourre-tout pour tout le monde.

Ta demande et donc ton problème sont différents.
Merci de fournir un compte test afin de pouvoir tester en direct pour trouver la source du problème.
Puis, quelle version a-tu installé ?
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
Avatar de ironside
France ironside
Auteur du sujet
Messages : 6
Enregistré le : 18 septembre 2020
Liquide : 79.70
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France ironside » 27 déc. 2021, 08:53
Bonjour

Version phpbb : 3.3.5
version php : 8.0
version Breizh Country Flag : 1.6.0

pour le compte administrateur , incris toi sous "sylver35" et je te mettrai admin/fondateur.

https://forum.ironside-legende.eu/index.php

Merci bien

cordialement
Image
Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 576
Enregistré le : 13 janvier 2018
Liquide : 3 478.95
Relax-Arcade :  2
Localisation : Bretagne
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France Sylver35 » 27 déc. 2021, 12:50
Ok, j'ai donc vu le problème :

code : Tout sélectionner

<img src="\&quot;https://forum.ironside-legende.eu/ext/sylver35/countryflag/flags/fr.png\&quot;" alt="\&quot;France\&quot;" title="\&quot;France" (fr)\"="" class="\&quot;flag-user" flag-35\"="" width="\&quot;35\&quot;">
Dans phpmyadmin, exécute cette requête :

code : Tout sélectionner

SELECT * FROM `phpbb_config` WHERE `config_name` LIKE 'countryflag_img%' 
Puis donne moi ici le config_value des 2 valeurs trouvées.
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
Avatar de ironside
France ironside
Auteur du sujet
Messages : 6
Enregistré le : 18 septembre 2020
Liquide : 79.70
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France ironside » 27 déc. 2021, 13:20
countryflag_img => <img src=\"%1$s\" alt=\"%2$s\" title=\"%3$s\" class=\"%4$s\" width=\"%5$s\" />
countryflag_img_anim => <img src=\"%1$s\" alt=\"%2$s\" title=\"%3$s\" width=\"%4$s\" />
Image
Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 576
Enregistré le : 13 janvier 2018
Liquide : 3 478.95
Relax-Arcade :  2
Localisation : Bretagne
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France Sylver35 » 27 déc. 2021, 13:46
Bien !
Donc, dans certaines configurations de sql, des antislashs \ sont ajoutés alors que dans 99.99 % des cas cela ne se produit pas :shock:
J'ai donc fait des protections dans le fichier core/country.php

Télécharge à nouveau sur github le zip et change ce fichier...
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
Avatar de ironside
France ironside
Auteur du sujet
Messages : 6
Enregistré le : 18 septembre 2020
Liquide : 79.70
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France ironside » 27 déc. 2021, 14:33
j'ai remplacé le fameux fichier , le drapeau ne s'afficher toujours pas , il y a "COUNTRYFLAG_SEPARATE" à la place.
Image
Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 576
Enregistré le : 13 janvier 2018
Liquide : 3 478.95
Relax-Arcade :  2
Localisation : Bretagne
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France Sylver35 » 27 déc. 2021, 14:40
Il manque apparemment tous les fichiers de langue de l'extension, cause de cela.
Tu n'a pas fait que remplacer le fichier core/country.php !
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
Avatar de ironside
France ironside
Auteur du sujet
Messages : 6
Enregistré le : 18 septembre 2020
Liquide : 79.70
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France ironside » 27 déc. 2021, 15:53
si, je n'ai fait que remplacé "coubry.php" comme tu m'avais demandé.
je vais tout remplacer alors.

ps: du coup là , le forum est planté :o
Image
Avatar de ironside
France ironside
Auteur du sujet
Messages : 6
Enregistré le : 18 septembre 2020
Liquide : 79.70
Pays :
France (fr)
France

Problème d'affichage drapeau countryflag

Message par France ironside » 28 déc. 2021, 09:18
Bonjour installation sur un forum tout neuf , vièrge de toutes extentions , le drapeau ne s'affiche toujours pas.
Image
  • Sujets similaires
    Réponses
    Vues
    Dernier message