Mises à jour/ConversionsLes photos n'apparaissent plus dans les messages

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2
Avatar de chefdesscouts
Francechefdesscouts
Auteur du sujet
Messages : 53
Enregistré le : 30 mars 2020
Liquide : 413.70
Pays :
France (fr)
France

Les photos n'apparaissent plus dans les messages

Message par Francechefdesscouts » 04 déc. 2020, 17:12
Bonjour,

Autre problème qui n'a rien à voir parce que antérieur à la mise à jour.

Les photos des messages antérieurs à 4/5 jours n’apparaissent plus (modifs de la shoutbox à ce moment là), seul leur "nom.jpg" est présent ?
les photos sont présentes "codées" chez mon hébergeur "EX2" mais la liaison ou "décodage" ne se fait plus.

3 heures plus tard../..
Voilà les dernières nles du front, j'ai téléchargé de chez mon hébergeur un "vieux" dossier "files" que j'ai réinjecté via filezilla en binaire sur mon serveur, avec ce nouveau "files" je visualise à nouveau les photos dans "gestion des fichiers joints", mais les photos n'apparaissent tjrs pas dans les messages, j'ai l'impression que le nouveau "files" n'est pas pris en compte à ce niveau là.


Avatar de Sylver35
FranceSylver35
Administrateur du site
Messages : 466
Enregistré le : 13 janvier 2018
Liquide : 2 457.15
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Les photos n'apparaissent plus dans les messages

Message par FranceSylver35 » 05 déc. 2020, 12:33
Bonjour,

Quoi qu'il en soit, la mise à jour de la shoutbox n'a rien à voir avec cela, elle ne touche pas aux fichiers joints !
j'ai téléchargé de chez mon hébergeur un "vieux" dossier "files" que j'ai réinjecté via filezilla en binaire
C'est alors donc lors de la mise à jour de phpBB que tu a touché à ce dossier alors que en suivant bien la procédure, on ne touche absolument pas à ce dossier.
j'ai l'impression que le nouveau "files" n'est pas pris en compte à ce niveau là.
Le cache du navigateur peut ne pas être étranger à cela.
Puis, tant que tu ne me donne pas les liens de messages en cause, je ne peut que supposer...
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
Avatar de chefdesscouts
Francechefdesscouts
Auteur du sujet
Messages : 53
Enregistré le : 30 mars 2020
Liquide : 413.70
Pays :
France (fr)
France

Les photos n'apparaissent plus dans les messages

Message par Francechefdesscouts » 05 déc. 2020, 13:04
Dans la mise à jour réussie selon tes conseils le répertoire "files" a été exclu comme il se doit, le défaut existait avant mais je ne m'en suis pas aperçu tout de suite, j'étais polariser sur les modifs de la shoutbox qui n'ont rien à voir.
Question: lors de transfert avec filezilla il apparait qu'il y a des problèmes avec le format "auto" faut-il privilégier le format "binaire".
Comme j'ai raté la première mise à jour PHPbb 3.3.2, j'ai récupéré mon forum en transférant une sauvegarde de "public html", je pense que c'est à partir de là que les images n’apparaissent plus ( pas grave il n'y en avait que 15 mais quelle est la mauvaise manip qui a provoqué cela, c'est ça qui est est intéressant)

https://www.nosboitesdereves.fr
Avatar de chefdesscouts
Francechefdesscouts
Auteur du sujet
Messages : 53
Enregistré le : 30 mars 2020
Liquide : 413.70
Pays :
France (fr)
France

Les photos n'apparaissent plus dans les messages

Message par Francechefdesscouts » 05 déc. 2020, 13:34
Sylver35 a écrit : 05 déc. 2020, 12:33
Le cache du navigateur peut ne pas être étranger à cela.
Puis, tant que tu ne me donne pas les liens de messages en cause, je ne peut que supposer...
En effet après avoir vidé le cache du navigateur "firefox" les images sont dans les messages.
Et c'est bien le dernier "files" transféré qui est pris en compte.

Pour les transferts avec filezilla, on laisse type de format en "auto" ?

Grand merci à toi !!
Avatar de Sylver35
FranceSylver35
Administrateur du site
Messages : 466
Enregistré le : 13 janvier 2018
Liquide : 2 457.15
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Les photos n'apparaissent plus dans les messages

Message par FranceSylver35 » 05 déc. 2020, 14:42
Pour les transfert en mode auto, tant que les fichiers ont une extension (.html, .php, etc...), tout va bien.
Mais quand il s'agit des fichiers joints qui ne comportent pas d'extension indiquée, alors le mode auto ne peut pas bien se comporter et systématiquement le transfert fait corrompre le fichier.
Il faut alors bien évidement mettre en binaire pour y palier...
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
  • Sujets similaires
    Réponses
    Vues
    Dernier message