Support de l'utilisationconnexion sécurisée https

Forum de support pour toutes les questions concernant l'utilisation de phpBB toutes versions. les problèmes rencontrés lors de manipulations et de la configuration du forum.
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 juin 2020, 19:36
Bonjour Sylver35

pourrai tu me donner toute la marche à suivre pour retenter de mettre mon fofo en https

j'ai essayer ce matin, mais sa marche pas je retombe toujours sur http en tapant https***

même en modifient le .htaccess
je dois oublier des choses :oops:

j'ai regarder plusieurs fois ici https://help.one.com/hc/fr/articles/360000297458-Pourquoi-le-protocole-SSL-HTTPS-ne-fonctionne-t-il-pas-sur-mon-site-

je crois comprendre qu'il est possible d'utiliser les deux (http et https)
chose que je voudrai faire pour voir si j'ai pas de souci comme la dernière fois je ne sais pas tout ce que tu a fait les dernière fois :|

merci Sylver


pour les passionés du potager: www.hortus-meo.be
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 353
Enregistré le : 13 janvier 2018
Liquide disponible : 2 240.20 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

connexion sécurisée https

Message par FranceSylver35 » 20 juin 2020, 19:58
Salut,

Je vient de le réactiver à l'instant.

Pour ce faire, il y a 3 étapes
  1. modification du .htaccess :
    J'ai dé-commenté les 2 lignes de http vers https :

    code : Tout sélectionner

    # redirection de http vers https
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    puis commenté les 2 lignes de https vers http :

    code : Tout sélectionner

    # redirection de https vers http
    #RewriteCond %{HTTPS} on
    #RewriteRule .* http://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
  2. Modification des données du serveur
    J'ai remplacé http:// en https:// et modifié le port du serveur de 80 vers 443
  3. Modification des paramètres des cookies
    J'ai changé le nom afin que cela soit effectif pour tout le monde et activé les cookies sécurisés.
Il ne faut pas laisser la possibilité des deux urls car sinon il y aura des problèmes de connexion et de sessions.
Bonjour la terre !!
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 juin 2020, 20:16
bonsoir et merci Sylver35

j’espère que cette fois sa continuera a fonctionner coté hébergeur
pour les passionés du potager: www.hortus-meo.be
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 sept. 2020, 12:34
Bijour Sylver

bon je reviens sur ce topic :mrgreen:

pour l'instant tout fonctionne toujours :)

mais j'ai jamais réussi a avoir le page index "sécurisé"


que la page index et post ou topic

les autres page il y a aucun souci
pendus, prono f1, relax arcade, sudoku etc.. tout ça c'est parfait

j'ai beau chercher des images ou lien en http, j'en est pas trouver

sur le code source de l'index, la seul chose en http que je trouve est ceci:

code : Tout sélectionner

var NotInClass = true;
	$(document).on('click',('a[href^="http://"], a[href^="https://"], a[href^="ftp://"]'), function() {
j'ai aucune idée de ce que c'est et si c'est ça la cause :|

pourrai tu m'aiguiller a résoudre ce souci ?

merci
pour les passionés du potager: www.hortus-meo.be
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 353
Enregistré le : 13 janvier 2018
Liquide disponible : 2 240.20 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

connexion sécurisée https

Message par FranceSylver35 » 20 sept. 2020, 14:30
Le bout de code que tu donne provient de l'extension pour ouvrir les liens externes dans un nouvel onglet et n'est pas en cause.

Pour trouver ce qui bloque la sécurisation, il te faut désactiver tous les blocs affichés sur l'index, voir si le cadenas change, puis les réactiver un à un en vérifiant à chaque fois.
C'est je pense la seule façon de trouver ce qui bloque.
Bonjour la terre !!
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 sept. 2020, 17:22
j'avais dàjà tenter ce que tu me dis, mais bon j'ai pas tout desactivé

je vais faire ça, tout désactivé les extension visible sur l'index
mais je devrai pas les trier par élimination; ceux afficher aussi sur le topic ?
car j'ai par exemple des blocs afficher sur l'index mais pas sur les topics :roll:
pour les passionés du potager: www.hortus-meo.be
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 sept. 2020, 18:25
sur le fofo test, j'ai pratiquement tout activé sur l'index
et la tout est bon, je suis en sécuriser
j'y comprend rien
pour les passionés du potager: www.hortus-meo.be
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 353
Enregistré le : 13 janvier 2018
Liquide disponible : 2 240.20 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

connexion sécurisée https

Message par FranceSylver35 » 20 sept. 2020, 18:30
Je ne peut plus aller sur ton fofo test, une extension mal codée produit une erreur :

code : Tout sélectionner

Erreur générale
SQL ERROR [ mysqli ]
Data too long for column 'log_ip' at row 1 [1406]
SQL
INSERT INTO test_mobile_logs (user_agent, log_ip, user_name, device_name, log_time) VALUES ('Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0', '2a02:a03f:54ce:8000:a4b3:2e55:4267:aec', 'Sylver35', 'mon-ordinateur', '1600619224')
C'est l'extension sniper/mobiledevice
Bonjour la terre !!
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 sept. 2020, 18:32
ah zut, j'ai du activé un peux trop d'extension :lol:
pour les passionés du potager: www.hortus-meo.be
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 143
Enregistré le : 25 novembre 2018
Liquide disponible : 1 055.90 ßzh
Pays :
Belgique (be)
Belgique

connexion sécurisée https

Message par Belgiquexpmen » 20 sept. 2020, 18:33
bah moi j'y est accès, aussi bien en invité que connecté :roll:
et sur mes deux navigateur
pour les passionés du potager: www.hortus-meo.be