Centre de documentationRendre compatible les extensions 3.2 pour phpBB 3.3

Ce forum contient des documentations liées à phpBB
Avatar du membre
FranceSylver35
Administrateur du site
Auteur du sujet
Messages : 353
Enregistré le : 13 janvier 2018
Liquide disponible : 2 240.20 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Rendre compatible les extensions 3.2 pour phpBB 3.3

Message par FranceSylver35 » 11 janv. 2020, 14:45
Cette documentation va vous permettre d'adapter les extensions compatibles avec phpBB 3.2 Rhea pour phpBB 3.3 Proteus.

Mise en garde :
Ceci apportera une compatibilité des fichiers .yml situés dans le dossier config d'une extension, cela ne garantit pas la compatibilité du fonctionnement de l'extension elle-même, mais est suffisant dans 95% des cas.

En effet, si vous devez attendre que les extensions soient mise en compatibilité pour Proteus 3.3, vous risquerez d'être couvert de toiles d'araignée avant que cela soit fait :mrgreen:
Le plus simple est alors de les adapter vous-même, il existe un outil très simple d'emplois pour ce faire.
David63 a fait une extension qui permet de voir quelles extensions sont compatibles et quelles modifications faire pour celle qui ne le sont pas, c'est Extensions .yml check disponible sur Github ici -> https://github.com/david63/extservicescheck

Téléchargez l'extension et installez là dans un dossier ext/david63/extservicescheck/ activez là.
Rendez-vous après dans l'onglet "Extensions .yml check"
Je vous donne la traduction fr pour la langue Française : Traduction FR

Voici le rendu de l'extension :
Image
Pour les extensions non compatibles, vous pouvez voir que l'icône n'est pas verte.
Il vous suffit de cliquer sur les icônes dans la colone ".YML FILE STATUS" pour voir ce qui ne vas pas et quelles corrections faire :
Image
Dans cet exemple, c'est pattern qui doit être remplacé par path
Image
Dans ce second exemple, ce sont les arguments qui doivent être entourés de guillemets simples, la correction est surlignée en jaune.

Les modifications doivent être apportées dans les fichiers .yml correspondants situés dans le dossier config de l'extension en cours
 ! Message de : Sylver35
Attention :
Suite à des bugs rencontrés, ne surtout pas faire de copié/collé du code modifié mais faire les modifications vous-même à la main.
Une fois toutes les modifications effectuées pour l'extension voulue, rechargez la page, elle doit passer au vert.


Bonjour la terre !!
  • Sujets similaires
    Réponses
    Vues
    Dernier message