Mises à jour/ConversionsAdvertisement Management --> "plantage" de mon clone

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2
Avatar de Pit
France Pit
Auteur du sujet
Messages : 35
Enregistré le : 07 avril 2020
Liquide : 572.50
Pays :
France (fr)
France

Advertisement Management --> "plantage" de mon clone

Message par France Pit » 06 févr. 2021, 20:04
Bonsoir

Dans le cadre de l'update de php 3.3.0 (que je prépare sur un clone de test), je dois mettre à jour cette extension phpbb/ads pour installer la v2.0.3.
J'ai donc supprimé la version précédente (1.0.5dev) et uploadé la v2.0.3 (bien que je n'avais pas la traduction française - je ne l'ai pas trouvée).
Dans un autre onglet de Firefox ouvert sur le PCA/Personnaliser, quand l'upload a été terminé, j'ai lancé un recontrôle de version des extensions pour vérifier que la nouvelle version était reconnue.
Il ne s'est pas effectué et quand je veux accéder au site je n'ai pas d'erreur mais une belle page blanche.
:shock:
En relisant les instructions, je viens de m'apercevoir que je n'avais pas désactivé l'extension et je me demande si ce n'est pas à cause de ça que j'ai le souci.
C'est peut-être une extension critique ??

Du coup, j'ai viré la nouvelle version et remis les fichiers de l'ancienne mais ça n'a rien changé, toujours une belle page blanche.
haaa*
Une idée pour sortir du guêpier où je me suis mis ?


Avatar de Sylver35
France Sylver35
Administrateur du site
Messages : 564
Enregistré le : 13 janvier 2018
Liquide : 3 414.80
Relax-Arcade :  2
Localisation : Bretagne
Pays :
France (fr)
France

Advertisement Management --> "plantage" de mon clone

Message par France Sylver35 » 06 févr. 2021, 20:49
Bonjour,
bien que je n'avais pas la traduction française - je ne l'ai pas trouvée
Il faut pour cela aller voir dans le sujet de l'extension :
https://www.phpbb.com/customise/db/extension/ads/support/topic/180776
J'ai donc supprimé la version précédente (1.0.5dev) et uploadé la v2.0.3
Pour mettre à jour une extension, il faut toujours :
. Désactiver l'extension
. Changer tout le dossier de l'extension avec le nouveau dossier
. Activer l'extension

Cela permet de mettre à jour la base de données avec les instructions de l'extension.
En relisant les instructions, je viens de m'apercevoir que je n'avais pas désactivé l'extension
Source du problème, oui.

Solution: désactiver l'extension dans la base de données, table ext recherche la ligne correspondante et met à zéro.
Ensuite, dans le dossier du forum, supprime le dossier cache/production/ puis va sur ton forum.
Tu peut alors reprendre là ou tu était...
Des chercheurs qui cherchent, on en trouve, mais des chercheurs qui trouvent, on en cherche !
Avatar de Pit
France Pit
Auteur du sujet
Messages : 35
Enregistré le : 07 avril 2020
Liquide : 572.50
Pays :
France (fr)
France

Advertisement Management --> "plantage" de mon clone

Message par France Pit » 06 févr. 2021, 21:14
:D
Super Sylver !

J'ai récupéré le forum grâce à toi, et j'ai appris quelque chose ce soir.
MERCI.
dancegirl
Bonne soirée.