Résolu Support des stylesProblème avec un thème perso

Le support pour tout ce qui concerne les styles de phpBB toutes versions.
Avatar du membre
FranceOrigin
Auteur du sujet
Messages : 39
Enregistré le : 03 janvier 2020
Liquide disponible : 276.15 ßzh
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceOrigin » 26 janv. 2020, 12:12
Salut,
Pour un forum j'ai créé, sur demande du membre, un thème perso sur la base du thème we_clearblue. En suivant la documentation du forum phpbb.fr
Ce thème s'installe et est fonctionnelle sauf pour la création et la réponse aux sujets. Les membres n'ont pas la possibilité de créer ou répondre lorsque ce thème est en place, en repassant sur le thème Prosilver tout est OK.

Où faut-il chercher la cause du problème ?


Avatar du membre
FranceSylver35
Administrateur du site
Messages : 385
Enregistré le : 13 janvier 2018
Liquide disponible : 2 166.15 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceSylver35 » 26 janv. 2020, 12:29
Bonjour,
Les membres n'ont pas la possibilité de créer ou répondre lorsque ce thème est en place
La première chose à se demander est :
Y a t-il le bouton "Nouveau sujet" ou "Répondre" là ou il doit se trouver ?
dans le forum, y a t-il les bonnes permissions indiquées :

code : Tout sélectionner

Permissions du forum
Vous pouvez poster de nouveaux sujets
Vous pouvez répondre aux sujets
Vous pouvez modifier vos messages
Vous pouvez supprimer vos messages
Vous pouvez joindre des fichiers
Car bien sûr, la cause n'est pas la même selon ce que l'on voit.
Bonjour la terre !!
Avatar du membre
FranceOrigin
Auteur du sujet
Messages : 39
Enregistré le : 03 janvier 2020
Liquide disponible : 276.15 ßzh
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceOrigin » 26 janv. 2020, 13:05
À priori oui puisqu'avec le thème Prosilver tout semble OK

Si cela fonctionne normalement avec le thème par défaut de phpBB cela devrait être OK avec le thème perso je suppose ?
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 385
Enregistré le : 13 janvier 2018
Liquide disponible : 2 166.15 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceSylver35 » 26 janv. 2020, 13:32
Ben non, pas du tout !
J'ai regardé un peu et c'est bien le code dans viewforum_body.html et viewtopic_body.html qui provoque cela.
Plusieurs choses ne vont pas. Il manque des choses et d'autres ne sont pas à la bonne place.
Pour le corriger, il faut le comparer avec des fichiers de prosilver.
Bonjour la terre !!
Avatar du membre
FranceOrigin
Auteur du sujet
Messages : 39
Enregistré le : 03 janvier 2020
Liquide disponible : 276.15 ßzh
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceOrigin » 26 janv. 2020, 13:58
OK
J'ai proposé une nouvelle version du thème en incorporant les templates manquants
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 385
Enregistré le : 13 janvier 2018
Liquide disponible : 2 166.15 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceSylver35 » 26 janv. 2020, 14:01
Les fichiers viewforum_body.html et viewtopic_body.html sont inclus dans le dossier template de ce style et ce sont eux qui sont en cause dans les bugs rencontrés.
La seule alternative est alors de les réparer ou de jeter ce style, pas de compromis entre les deux...
Bonjour la terre !!
Avatar du membre
FranceOrigin
Auteur du sujet
Messages : 39
Enregistré le : 03 janvier 2020
Liquide disponible : 276.15 ßzh
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceOrigin » 26 janv. 2020, 14:07
J'ai bien compris mais comme ce style est compatible 3.2.9 en plaçant ces 2 templates, oubliés initialement, cela devrait régler le problème si je ne m'abuse ?

J'ai mis ce thème sur mon forum test en 3.3.0, à part le soucis de navbar, les membres peuvent bien poster et répondre.
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 385
Enregistré le : 13 janvier 2018
Liquide disponible : 2 166.15 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceSylver35 » 26 janv. 2020, 14:13
Comme tu n'avais pas indiqué de version phpBB, j'ai pris en compte la version pour 3.3.0 et cette version comporte ces fichiers.
Ne pas mélanger les 2 versions et toujours bien indiquer la bonne.
Puis, comme phpBB version 3.2 ne sera bientôt plus soutenu, rien ne sert de s'investir pour si peu de temps.
La version pour 3.3 est ici -> https://www.phpbb.com/community/viewtopic.php?t=2535576 et comporte des bugs.
Un utilisateur a déjà demandé du support pour ces bugs et le créateur est buté en indiquant de revoir les permissions ! :o
Bonjour la terre !!
Avatar du membre
FranceOrigin
Auteur du sujet
Messages : 39
Enregistré le : 03 janvier 2020
Liquide disponible : 276.15 ßzh
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceOrigin » 26 janv. 2020, 14:25
Sauf que ce thème sur mon forum test en 3.3.0 ne comporte pas de bug aux niveau des permissions
Avatar du membre
FranceSylver35
Administrateur du site
Messages : 385
Enregistré le : 13 janvier 2018
Liquide disponible : 2 166.15 ßzh
Relax-Arcade :  3
Localisation : Bretagne
Pays :
France (fr)
France

Problème avec un thème perso

Message par FranceSylver35 » 26 janv. 2020, 14:40
Mais !! je te l'ai déjà dit, il ne peut pas y avoir de problèmes de permissions entre un style et un autre !!
Les permissions sont gérées dans le core php, pas dans le html.
Juste que les 2 fichiers précédemment cités comportent des bugs, du code manquant et du code non situé au bon endroit.
Ce qui provoque les problèmes rencontrés.
Bonjour la terre !!
  • Sujets similaires
    Réponses
    Vues
    Dernier message