[Réglé] Support de l'utilisationProblèmes d’accents après installation forum

Forum de support pour toutes les questions concernant l'utilisation de phpBB toutes versions. les problèmes rencontrés lors de manipulations et de la configuration du forum.
no_avatar
FranceJessy
Auteur du sujet
Messages : 4
Enregistré le : 12 juil. 2019, 22:10
Liquide disponible : 99.10 ßzh
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceJessy » 12 juil. 2019, 22:54
Bonjour Sylver,

J’ai changé d’hébergeur Il y a quelques jours et me voilà en possession d’un problème. Après avoir transféré tous les fichiers et dossiers de l’ancien hébergeur, et ayant au préalable créé la bdd, mon forum est assez illisible.

En effet, tous les mots contenant des caractères avec accents sont illisibles.
Exemple, le mot Règlement s’affiche comme ceci: Règlement

C’est assez gênant pour tout le monde.

Je précise que je n’avais pas ce problème chez mon ancien hébergeur qui était PlanetHoster (la je suis che Ovh...)

Mon Phpbb est en 3.0.12 et fonctionne parfaitement. J’avais installé beaucoup de Mods ainsi que ta shoutbox V 1.0.5 qui fonctionne encore à ce jour.

A vrai dire je n’ai pas trop l’envie de passer le forum en 3.2.7 car je vais perdre quasi tous mes Mods voire le style etc...

J’ai contacté le support Ovh qui n’ont pas de solution à c souci d’accent...

C’est la raison pour laquelle je me tourne vers toi, étant donné que tu étais déjà intervenu à l’epoque Sur mon forum.

Par avance merci de l’aide que tu pourrais éventuellement m’apporter.

Amicalement.

Capture du souci d’accents:
Image

HTTP://zenatssytude.fr
Modifié en dernier par FranceJessy le 18 juil. 2019, 17:45, modifié 2 fois.



Avatar du membre
FranceSylver35
Administrateur du site
Messages : 212
Enregistré le : 13 janv. 2018, 15:04
Liquide disponible : 1 225.55 ßzh
Solde : 205.00 ßzh
 
Relax-Arcade :  4
Localisation : Bretagne
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceSylver35 » 13 juil. 2019, 07:38
Bonjour Jessy et bienvenue,

Pour ton problème de caractères encodés, cela s'est certainement produit lors de la sauvegarde.
Donc, la question: a-tu conservé le fichier de sauvegarde de ton ancien hébergeur afin que je le vérifie?
De plus, cela dépend de l'encodage que tu a défini dans ta nouvelle base de données, il doit être en UTF-8
J’ai contacté le support Ovh qui n’ont pas de solution à c souci d’accent...
Tu m'étonne, des personnes qui n'y connaissent pas grand chose, des incapables qui font de la figuration...
Mon Phpbb est en 3.0.12 et fonctionne parfaitement. J’avais installé beaucoup de Mods ainsi que ta shoutbox V 1.0.5 qui fonctionne encore à ce jour.
Je te conseille très vivement de passer le pas tout de même car plus aucun support ne peut être fourni ailleurs et des bugs de sécurité connus sont présents dans ton forum.
Pour les mods installés, pas de soucis, la plus grande partie est existante en extensions.
Ces extensions s'installent en un clic très simplement, plus de fichiers à modifier.
Pour le style, tu peut en trouver un qui s'en approche, il suffit de se décider et tes membres apprécieront.
Bonjour la terre !!

no_avatar
FranceJessy
Auteur du sujet
Messages : 4
Enregistré le : 12 juil. 2019, 22:10
Liquide disponible : 99.10 ßzh
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceJessy » 13 juil. 2019, 08:16
Hello Sylver,

Merci pour ta réponse.

J'ai bien conservé la sauvegarde de l'ancien hébergeur, je te la fait parvenir via Mp pas de souci.
Au besoin je te donne tous les accès (je te fais entièrement confiance vu que tu es déjà intervenu par le passé).
De plus, cela dépend de l'encodage que tu a défini dans ta nouvelle base de données, il doit être en UTF-8
Comment le vérifier ? Dans PhpMyAdmin ? Etrange chez Ovh lors de la création de la BDD je n'ai pas renseigner d'encodage, cela c'est fait automatiquement.

Pour la mise à jour du forum, effectivement je pense franchir le cap. Je ferai tout cela à tête reposée et surtout en local dans un premier temps.

Autre détail qui a peut être son importance:
sur l'hébergeur j'ai changé plusieurs fois de versions de PHP (5.4; 5.5 et 5.6) proposées par ovh
les versions 7.0; 7.1; 7.2 et 7.3 ne sont pas compatibles avec mon forum (affichage étrange et en décalage)

Avatar du membre
FranceSylver35
Administrateur du site
Messages : 212
Enregistré le : 13 janv. 2018, 15:04
Liquide disponible : 1 225.55 ßzh
Solde : 205.00 ßzh
 
Relax-Arcade :  4
Localisation : Bretagne
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceSylver35 » 13 juil. 2019, 09:30
sur l'hébergeur j'ai changé plusieurs fois de versions de PHP (5.4; 5.5 et 5.6) proposées par ovh
les versions 7.0; 7.1; 7.2 et 7.3 ne sont pas compatibles avec mon forum (affichage étrange et en décalage)
C'est pourquoi il est important de passer à la version 3.2 car ton forum n'est pas compatible php 7.x, uniquement php 5.x qui va disparaitre définitivement dans peu de temps

Fait moi un compte admin chez toi et un accès phpmyadmin.
Je part en vacances juste maintenant et serait moins dispo pendant une semaine.
Bonjour la terre !!

no_avatar
FranceJessy
Auteur du sujet
Messages : 4
Enregistré le : 12 juil. 2019, 22:10
Liquide disponible : 99.10 ßzh
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceJessy » 13 juil. 2019, 10:56
Voilà Sylver, c'est fait via Mp. :D

Avatar du membre
FranceSylver35
Administrateur du site
Messages : 212
Enregistré le : 13 janv. 2018, 15:04
Liquide disponible : 1 225.55 ßzh
Solde : 205.00 ßzh
 
Relax-Arcade :  4
Localisation : Bretagne
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceSylver35 » 18 juil. 2019, 18:16
Je donne la manière que j'ai utilisé pour résoudre le problème d'encodage des caractères accentués dans la totalité de la base de données.

J'ai ouvert la sauvegarde (fichier .sql) avec notepad++
J'ai ouvert la boite de recherche, onglet "Remplacer", mis les caractères à rechercher, par exemple è dans la ligne "Rechercher:" pour le è que j'ai mis dans la ligne "Remplacer par:"
Puis j'ai cliqué sur 'Remplacer tout"
Cela permet de remplacer toutes les occurrences du même type en un seul clic.
Puis, il faut alors rechercher la totalité des encodages pour tout résoudre.
Ne pas oublier de toujours enregistrer vos fichiers avec notepad++ en UTF-8 (sans BOM)

Ensuite, j'ai zippé le fichier puis je l'ai utiliser pour écraser la totalité du contenu de la bdd.
Bonjour la terre !!

no_avatar
FranceJessy
Auteur du sujet
Messages : 4
Enregistré le : 12 juil. 2019, 22:10
Liquide disponible : 99.10 ßzh
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceJessy » 18 juil. 2019, 21:11
Hello

Du coup quand on importe une Bdd via PhpMyadmin est-il préférable d'importer un Zip ? Par rapport à un simple .sql
je me pose la question.

Et encore une fois un tout grand merci Sylver !

Avatar du membre
FranceSylver35
Administrateur du site
Messages : 212
Enregistré le : 13 janv. 2018, 15:04
Liquide disponible : 1 225.55 ßzh
Solde : 205.00 ßzh
 
Relax-Arcade :  4
Localisation : Bretagne
Pays :
France (fr)
France

Problèmes d’accents après installation forum

Message par FranceSylver35 » 20 juil. 2019, 17:11
Oui, il est bien préférable d'utiliser une sauvegarde compressée en zip ou gzip car ainsi, la charge diminue très fortement et les risques de dépassement du temps ou de la capacité de mémoire sont réduits.

Par ailleurs, je déconseille très vivement d'utiliser la sauvegarde de bdd avec le module incorporé à phpbb qui sera de fait inopérante en cas de plantage.
Préférer à cela Mysqldumper
Bonjour la terre !!

  • Sujets similaires
    Réponses
    Vues
    Dernier message