[Réglé] Mises à jour/Conversionsconflit mise à jour 3.2.9

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.2
Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 102
Enregistré le : 25 nov. 2018, 12:13
Liquide disponible : 780.75 ßzh
Pays :
Belgique (be)
Belgique

conflit mise à jour 3.2.9

Message par Belgiquexpmen » 11 janv. 2020, 17:49
Bonjour

j'ai commencer la mise à jour de 3.2.8 vers 3.2.9 (fofo test)
et il me met un fichier en conflit

composer.lock
Les fichiers suivants ont été modifiés et ne correspondent plus aux fichiers originaux de l’ancienne version. phpBB a déterminé qu’il ne pouvait pas fusionner ces fichiers sans créer de conflits. Veuillez rechercher les conflits et essayez de les résoudre manuellement ou continuez la mise à jour en choisissant l’une des méthodes de fusion. Si vous résolvez les conflits manuellement, vérifiez à nouveau les fichiers après leur modification. Vous pouvez aussi choisir l’une des méthodes de fusion pour chaque fichier. La première donnera un fichier où les modifications contenues dans les lignes en conflit seront perdues, l’autre ignorera les modifications du nouveau fichier.
dans l’énoncé il me propose une des méthodes de fusion, mais je ne la vois pas afficher :shock: :shock:
quand a trouver et corriger les conflits, bah j'ai éditer le fameux fichier, mais je ne sais même pas ce que je dois chercher, trouver et corriger :?

bref j'ai arréter la mise à jour et tout laisser en attente de savoir quoi faire :oops:


pour les passionés du potager: www.hortus-meo.be

Avatar du membre
FranceSylver35
Administrateur du site
Messages : 226
Enregistré le : 13 janv. 2018, 15:04
Liquide disponible : 1 316.90 ßzh
Solde : 205.00 ßzh
 
Relax-Arcade :  4
Localisation : Bretagne
Pays :
France (fr)
France

conflit mise à jour 3.2.9

Message par FranceSylver35 » 11 janv. 2020, 18:02
Salut xpmen,

A ce que je voit, tu a utilisé le pack de mise à jour 3.2.8 vers 3.2.9
Je te déconseille très fortement cela, peut-être qu'un jour ils comprendront chez phpbb qu'il est temps qu'ils oublient ces packs créateurs de bugs en tous sens.

Bref, le méthode que je te conseille est :
Ne pas prendre de pack de mise à jour mais le pack complet 3.2.9 "Télécharger le pack français" -> http://www.phpbb-fr.com/telechargements/

Pour cela, il faut faire une sauvegarde de la base de données dans phpmyadmin que tu conserve bien au chaud.
Il te faudra mettre directement sur le serveur les fichiers neufs de phpbb 3.2.9
Tu télécharge le dernier pack complet de phpbb ici -> http://www.phpbb-fr.com/telechargements/
Dans ce pack décompressé, tu doit retirer:
Les dossiers | ext | files | images | store |
Les fichiers config.php et .htaccess

Puis, tu envoie le pack dans ton serveur en lieu et place des anciens dossiers/fichiers en cochant la case "remplacer".

Un fichier s'est certainement créé dans le dossier store: install_config.php, tu le supprime afin de reprendre la maj comme il faut.

A ce moment, il te reste alors à mettre à jour ta base de données en pointant sur le dossier install/
Tu doit choisir l'onglet mise à jour et suivre les instructions.
La vérification des fichiers ne sera pas faite car tous les fichiers sont déjà à jour!

Il te faut aussi mettre à jour ton style à la main (uniquement les fichiers présents dans ton style):
http://forums.phpbb-fr.com/documentatio ... -view.html
Bonjour la terre !!

Avatar du membre
Belgiquexpmen
Auteur du sujet
Messages : 102
Enregistré le : 25 nov. 2018, 12:13
Liquide disponible : 780.75 ßzh
Pays :
Belgique (be)
Belgique

conflit mise à jour 3.2.9

Message par Belgiquexpmen » 11 janv. 2020, 19:10
kikoo Sylver

oki, je vais faire ça ;)
j'avais utiliser le pack pour évité de refaire mes modif sur certain fichiers
mais bon, je note tout ce que je fait donc sa va aller ;)

merci Sylver
pour les passionés du potager: www.hortus-meo.be